ECCUBEの管理画面のSSL設定をインストール後に変更する方法
2017/03/08
ECCUBEの管理画面のSSL設定方法
ECCUBEの管理画面の SSL設定を変更する場面
ECCUBEをインストールし、運用している環境に対して
・管理画面を SSL対応にする場合
・管理画面を非 SSL化する場合
の対応方法についての解説です。
前者のイメージとしては、開発中、もしくは、運用開始時点では SSLの設置をしていなかったものの、SSLの設置をしたので管理画面を SSL化したい、という場合があるでしょう。
後者のイメージとしては、管理画面を SSL化して運用している本番環境を元にして開発環境を構築したいが、開発環境なので SSLはないので非 SSL化したい、という場合があるでしょう。
今回の私は後者の対応の方法を調べたワケですが、その方法を解説します。
[amazonjs asin=”4899774389″ locale=”JP” title=”EC-CUBE 3 店舗運営&デザインカスタマイズガイド”]
管理画面の SSL設定の変更方法
今回の説明は、管理画面が強制 SSL設定になっている設定を非 SSL化する想定です。
対応するファイルは、下記になります。
{ECCUBEのフォルダ}/data/config.php
変更する箇所は 2カ所です。
define('HTTPS_URL', 'https://localhost/html/');
↓
define('HTTPS_URL', 'http://localhost/html/');
「HTTPS_URL」の設定を https://~ となっている部分を http://~ に変更します。
define('ADMIN_FORCE_SSL', FALSE);
「ADMIN_FORCE_SSL」を「false」にします。
項目名を見ても分かると思いますが、管理画面に対して SSLを強制するか否かの設定項目です。
インストールする際に下記の項目で設定する項目です。
ここにチェックを入れていると、SSL経由(https://~)でのアクセスが強制されます。
http://~ でのアクセスができなくなります。
チェックを入れると「ADMIN_FORCE_SSL」が「true」になります。
強制的に SSL経由でのアクセスをする場合は「true」を指定します。
管理画面の SSL設定に関連して確認するポイント
そもそもの話として、ECCUBEの環境を、本番環境から開発環境に移設する、サーバを引越しする、本番公開時にドメインを設定する、といった環境の状況が変わる場合の対応方法については、下記に記事を書いていますので参考にしてください。
ECCUBEを開発環境から本番ドメインに変更でエラーが・パス変更について
ファイル変更だけ!ECCUBEの本番から開発環境をコピーする手順を解説
標準機能で ECCUBEを運用している場合はおおよそ前項の解説の内容で足りるのですが、ECCUBEのルートや adminフォルダで .htaccessを設定してリダイレクト設定をしている場合は、その設定の影響で不具合を起こす場合もありますので、前項の設定だけで表示されない場合は、.htaccessの設定も確認してみましょう。
場合によってはリダイレクトループのエラーが起こっている場合もありますので。
リダイレクトループについては「リダイレクトループが原因で「ERR_TOO_MANY_REDIRECTS」「このページを表示できません」が出たときの対策12事例+α」に記事を書いていますので参考にしてみてください。
この記事が参考になったと思いましたらソーシャルメディアで共有していただけると嬉しいです!
関連記事
-
-
ECCUBEを開発環境から本番ドメインに変更でエラーが・パス変更について
レンタルサーバでサーバ会社から割り当てられたURLで開発し、本番公開時にドメインを当てたらエラーが!そんな場合の対処方法の解説。対処方法は簡単ですが管理画面からは対応不可。
-
-
路線・駅検索をPHPで実装する方法解説。GoogleMapsの緯度経度から計算し検索
路線・駅検索の仕組みの構築は大変。登録する側も最寄り駅が多い場合は大変。なので簡易に実装するため緯度経度に基づき直線距離を計算する処理を考案して実装して、その処理を解説。
-
-
Smartyの修飾子regex_replaceで正規表現の後方参照・PHPではpreg_replace
ECCUBEで使われているSmartyで文字列を正規表現で置換し後方参照で値を利用する装飾子regex_replaceの解説です。細かな条件がありますので注意が必要です。
-
-
AdminerはphpMyAdmin代替のデータベース管理ツール
AdminerはphpMyAdminとほぼ同機能のデータベース管理ツール。PHP 1ファイルのため設置が非常に簡単で軽快に動作し、phpMyAdminの置き換えで使うのも問題なし。
-
-
ECCUBE2.13.3で商品規格の在庫数が無制限から変更できないバグがある
2.13.3固有のバグである商品規格の在庫数の入力エリアがアクティブにならない不具合を解消する解説です。product_class.tplの2行を修正するだけの簡単対応です。
-
-
PHPのデバッグで使う print_r、var_dump、var_exportの動作の違い
PHPのデバッグ等で変数や配列の中身を確認するために使用する関数print_r、var_dump、var_exportの動作の違い、仕様の違いについて確認した。var_exportがオススメ。
-
-
複数銘柄を指定して株価チャートを一覧するツール公開
入力銘柄の5日間、3か月間、6か月間、1年間、2年間の株価チャートを一覧表示しますのでチャートで売買判断をするのに最適です。
-
-
ECCUBEでアップロードできない。upload_max_filesizeを設定する場所
テンプレートをアップロードする際に発生するエラー「テンプレートファイルがアップロードされていません」の対処方法。これはファイル容量の制限に引っかかっています。
-
-
PHPパーミッション変更のchmod関数・モードを変数で指定する方法
パーミッション変更関数であるchmod関数の第二引数、ファイルモードの指定に変数を使う場合は8進数に変換するoctdec関数を使って変換します。
-
-
サーバ移転、PHPバージョンアップでPHPのソースコードが表示される・ショートタグのPHPが動かない
PHPでショートタグを使うのは危険。サーバ移転やバージョンアップで動かなくなる!ソースが丸見え、設定情報流出のリスクが!php.iniのshort_open_tagの設定を再確認。
